2 routers- does it work?

Created by forrestpock on Sept. 14, 2017, 5:51 a.m.
  • Hello,

    I am new here and found old topic explaining how to connect 2 routers together. Great info there and I am successful.

    I have wired connection and given 2 routers same name. Second one is set up as AP, of course. Both working and I can access setting pages no problem.

    My problem is that my mobile does't switch between routers automatically as range does't improve. Of course my mobile is set to connect automatically.

    Now I have given different name to AP router and can see both. I can switch manually between and both providing internet connection.

    Can you please advise me how to make sure what they switch automatically?


    When I give same name to both routers I can see one network. How I can see which I am connected to and if my devises switch automatically?

  • This is a difficult problem on standard networking hardware. Generally unless you are completely out of range of the first network, your device will not switch to the second. So if you can put the routers that far apart you may have some success. Additionally some asus routers have a feature that allows you to force disconnect clients that have a low signal strength. With some tuning this could probably achieve what you describe. Otherwise the easiest solution if you have the money would be a mesh setup of some sort (eero, etc. there are many options nowadays). Oh and one last thing, are the routers positioned across the house? or are they both in the same place?

    And regarding your last question, the easiest way I know of is using the wifi MAC address of the router (number unique to that exact router.) If your mobile device is android you can do this: enable developer settings by going to Settings > About Phone and tapping Build Number repeatedly until it say "Congratulations you are now a developer" Then go to Developer options and look for an option like "Enable wifi verbose logging" (or similar) which should turn on showing the multiple routers with the same name in your wifi settings page. (compare these to the stickers on the bottom of your routers which should contain the wireless MAC number)

  • Hello,

    Thank you for taking time to answer.

    I have positioned routers in different places in the house, upstairs and downstairs.

    I see is not easy. I'll try verbose logging.


  • @forrestpock: Try that, might work.

  • Another way to help with this sounds backwards but it will help.

    Go into the settings of each of the routers and turn down the power of the WiFi transmitter. What you are explaining is over lap of the two routers. This was common in the older non controller setups with WiFi. Modern mesh WiFi networks have a unit that acts like a controller that aids in the device hand off from one AP to the other. Since you are using older tech you have to force the device to jump from one AP to the other. Simply turning down the transmitter power will help this. Also adjusting the antenna so they cover the most area and minimize the over lap helps too. You can get it better but it will always be an issue.