Opening port 25565: Hosting a Minecraft server

Created by Seriousface on March 15, 2012, 6:53 p.m.
  • Type your IP address into your browser (by default it should be 192.168.0.1, but you can check here or using the "run" program, typing "CMD" and hitting "run", and typing "ipconfig", at which point a bunch of numbers will show up, and one of them is your IP address). There should be some kind of "advanced port forwarding" option, though each router/isp is a little different for this.  
  • @seriousface: Well, it definitely won't work with Inbound Filter set to Deny All. Just leave it as Allow All.
     
    Try setting the ports as a single port, instead of a range. It probably won't make a difference, but it's worth a try.
  • You shouldn't have two different IP addresses using the same ports. You have Minecraft using 192.168.0.0, and MC server 192.168.0.190.   
     
    The first thing you need to do is find your computers IP.  The address will be listed as IPv4 Address. Start>Run>CMD>IPconfig. 
      

     
    Next go back into your router, and change it so you only have one Program using ports 25565-25565, so Instead of having Minecraft and MC server just use Minecraft. Then take the IP we got from the first step and put it into the IP address for the program. 

     
    Last step go to www.ipchicken.com to find out your out side IP address. This is the IP you will give to your friends so they can join the server. 
  • Plug your computer straight into your modem and see if someone can connect. If not, then you need to look somewhere else besides the router.
  • Hmmm. Where does it say the port is offline? Also could you post an updated picture of your ports.
  • @seriousface: 
     
    Are your router and your modem on different continents or something? What's hard about unplugging a cable and plugging it in somewhere else? You can waste time fiddling with your router until you get so frustrated you end up setting it on fire, or you can spend 30 seconds verifying that the router is the problem in the first place.
     
    E: Just realized you're probably on wireless in a remote part of the house or something, so sorry if I sounded rude. Still, this is going to be the most effective thing you could try, so you really ought to try to figure out a way to do it.
  • If you are using comcast, I know they block a whole hell of alot of ports just from them.  Comcast are like the the Fratellis from the Goonies
  • @GTFShadow said:

    " If you are using comcast, I know they block a whole hell of alot of ports just from them.  Comcast are like the the Fratellis from the Goonies
    "

    I'm Norweigan, so no. 
     
    @lane said:

    " @seriousface:   Are your router and your modem on different continents or something? What's hard about unplugging a cable and plugging it in somewhere else? You can waste time fiddling with your router until you get so frustrated you end up setting it on fire, or you can spend 30 seconds verifying that the router is the problem in the first place.  E: Just realized you're probably on wireless in a remote part of the house or something, so sorry if I sounded rude. Still, this is going to be the most effective thing you could try, so you really ought to try to figure out a way to do it. "

    It's downstairs, and so is the router. The cord goes through the wall and upstairs into my room :) No wireless. I'm obviously not on a laptop.
  • @seriousface:

    Can you post a picture of the network status page for your D-Link where ti will show the address assigned to your router. Actuay dont post it just private message me it. I am currious if this a double nat situation.
  • If your sure 192.168.0.190 is your computers IP then everything looks set up correctly. The only other suggestion is maybe change the ports from 25565-25565 TCP and 25565-25565 UDP to 25565 TCP and 25565 UDP. Also if your running any firewalls you need to make sure to allow Minecraft through it.  Other than that I don't know what could be the problem. 

  • Its a double NAT guys. The modem has router functionality with a NAT firewall. also all documentation is Norweigan lol thanks google translator
  • @cripplecaptain: 
     
    That's what I figured, which is why I recommended plugging straight into the modem.
  • @lane:
    Yeah I see it on a daily basis now stupid ISPs when are they going to learn if you cant make a good router then dont bother including one at all. and if you DO then add a port that is seperate from the intergated routing.
  • @cripplecaptain: 
     
    Well, to be honest, I'd rather see that than granny hooking her Windows 98 machine straight into the wide open Internet.
  • @lane:
    well I still see plenty of that. Infact for kicks if you havent tried this and you are on cable internet (dont think dsl allows it) boot up a live cd and plug directly into the modem and you usualy hit an open windows share but cycleing through your network segment with the preceding \\ slashes I found several on my segment one day with the everyone read write permission for the c$ share.  
     
    But yes then I suppose I would like to see my latter suggestion of a seperate port for adding your own router outside of the modems nat.
  • @lane:  lol, true that machine would be eaten alive :/
  • So, what do I do? :D
  • @seriousface: 
     
    Plug your computer straight into the modem.
     
    Then you're going to have to figure out how to log into the modem's administrative interface. Usually there's instructions on the bottom of the modem. You want to find a setting that passes the signal straight through to your router - usually it's called "bridge mode" or something similar. Once you check that off, you should be good to go.
  • @lane said:

    " @seriousface:   Plug your computer straight into the modem.  Then you're going to have to figure out how to log into the modem's administrative interface. Usually there's instructions on the bottom of the modem. You want to find a setting that passes the signal straight through to your router - usually it's called "bridge mode" or something similar. Once you check that off, you should be good to go. "

    Cool. I'll try that tomorrow (its 11:30 pm atm). Dammit, hoped that I could avoid moving my computer, it's kind of heavy  :P I will report back when I've done that
  • @seriousface: 
     
    Is there no way to do it with that existing cable?
  • @lane said:
    " @seriousface:   Is there no way to do it with that existing cable? "
     
    If it was 1m longer ):
  • Why not just move the cable from where it's plugged into the router and plug it into the modem, that way you dont have to move your computer.
  • I think I can move the modem. Maybe. If I find a longer cable somewhere. I'll look tomorrow, going to bed now

  • Good lord port forwarding hurts my brain something fierce.  I've never been able to get any of that crap to work properly when I wasn't running DD-WRT/Tomato/m0n0wall. 
     
    Why don't you just DMZ your box?  Or did I miss that suggestion? 
     
    EDIT: 
    As for the double NAT, depending on your router make and model, you can typically find the IP address it uses on the internet, plug a machine directly in to it, and try to bypass the double NAT that way.
  • @Helushune: 
     
    DMZ wouldn't work because the port's blocked at the modem, not the router.
  • @lane said:
    " @Helushune:   DMZ wouldn't work because the port's blocked at the modem, not the router. "

    Right, double NAT crap...  Yeah, the only thing to do is hope the modem offers some kind of configuration.  If not, up the creek without a paddle.
  • @Helushune well you can actualy double port forward your ports
  • @cripplecaptain said:
    " @Helushune well you can actualy double port forward your ports "
    Madness, sir.   Absolute madness.  Well, hopefully we can figure out a solution.
  • Ok, I've been doing some reading around on some Norwegian forums and it looks like all Ventelo modems are set to bridge-mode by default. I also tried connecting the modem directly to my PC but nothing happened, and i didnt find any instructions on how to get a config screen up. There is also no web-interface or anything like that to change the settings on the modem, i found out after I read some more 
     
     I am also using a switch, maybe that is the cause of my troubles?

  • No idea what you just said :)