Huge Bug in Intel SSDs: Complete Recovery Information Here

Created by lane on May 7, 2012, 2 a.m.
  • As I learned this weekend, Intel SSDs have a major firmware bug: under certain power loss conditions, the drive can become completely bricked and unbootable. This bug will manifest itself by displaying a drive size of 8MB and a serial number of "BAD_CTX 00000130" in the BIOS. The issue was supposedly addressed in the latest firmware, 4PC10362, as described here. However, the bug still persists in the latest version. The good news is that a bricked drive can be restored to a working state; the bad news is that the restoration process will destroy any data on the drive. I'm compiling all the information for fixing this problem here in one place since I spent a few hours looking around for a solution and only found bits and pieces of what I needed as I went and I wanted this thread to serve as a useful repository of information for those who encounter this issue as I did.

    Restoring an Intel SSD affected by the 8MB bug:

    1. Download and burn a bootable MHDD CD using the .iso file found here. (You can burn an .iso file using the built-in Windows 7 image burning tool or with a free tool such as ImgBurn.)

    2. Place the MHDD CD in your CD-ROM drive and boot your computer. You may have to change your boot order in the BIOS or press F12 during the boot process to force your computer to boot from CD-ROM first.

    3. When MHDD starts up it will ask you if you want to start with or without SCSI support. If this means nothing to you, then either option will work.

    4. MHDD will then display a list of drives installed on your system. Type in the number corresponding to the affected Intel drive and press Enter.

    5. A password must be set on the drive before you can restore it. Type "PWD" at the MHDD command prompt and enter something short and memorable like "password". You will only need to remember this for the duration of this process. Some BIOSes may lock the drive during the boot process. If the PWD command fails, then unplug your SSD and plug it back in once MHDD has started to avoid having it locked during boot.

    6. Type "FASTERASE", hit Enter, then enter the password you set in the previous step and hit Enter again. The word "BUSY" at the top of the screen will flash for a bit. When it stops, the process is complete.

    7. Press F2 to re-detect the drive information. If all has gone well, you should see the correct drive information now displayed at the top of the screen.

    8. Type "UNLOCK" and enter your password to unlock the drive, then "DISPWD" to clear the password permanently.

    9. Remove the disc and reboot your computer. Your drive should now be back to its original from-the-factory state. Install your OS of choice and so forth as usual.

  • Sheeeeeeeeeeeeeeeeeeeeeeeeeet. Both my SSDs are Intel. Thanks for the info. Bookmarking this in case they get borked.

    Edit: Hm. While I'll need to check what my laptop has, it appears that my desktop may not be affected, as I have a 520 Series drive.

  • Does this still apply to the 330 and 520 drives?

  • @Fish_Face_McGee:

    I kind of wonder if their inability to squash this bug is part of the reason they moved to Sandforce controllers for the 520.

  • @stenchlord: Unless Lane knows differently, I don't believe the 520 is affected. At the very least, I know the 520 is on a separate firmware naming convention (and install process) than the 320. I don't know how the 330 differs.

  • Jeeze man I only just bought an intel SSD like 5 days ago, now luckily seeing as it was a 520 I'm safe, but not the news I was looking for this early in.

  • @stenchlord:

    The 330 and 520 use Sandforce controllers, so I highly doubt it.

  • Great post here Lane! This will def come in handy if others have this issue!

  • Well, shit. My laptop has a 320. Well, I'm glad I've bookmarked this, anyway. Thanks for the head's up, Lane!

    Edit: I just checked, and I have different firmware than the supposed newest. My 320 has 4PC1LE04. It appears Lenovo may have made custom firmware for its laptops' SSDs, which is crazy.

  • @Fish_Face_McGee:

    If you avoid unexpected shutdowns you should be okay. I don't know what happened with mine; we never lost power at the house or anything. Maybe a hiccup from the PSU? Anyway, if you have a charge on your battery it's probably fine.

  • @lane: Yeah, the laptop does a good job of keeping a charge, so I'm not super worried. I'm also making sure to sync everything to SkyDrive, so if I have to wipe it, I'm OK.

    Again, I really appreciate the head's up. I tried briefly Googling the issue, and there doesn't seem to be too much documentation about how to handle it, so I'll know what to do if the laptop drive

  • Good news: If you run into the bad_ctx error or 8 MB bug in the Intel 320 Series SSD, the data can be recovered by us at Gillware. This is a breakthrough for the data recovery industry, and we believe we are the only lab with this ability. Please contact Gillware Data Recovery if you need data recovered from Intel SSDs; we charge only if you decide we were successful after you review a directory of recovered files. Sorry for sales pitch, but wanted to let people know there's now a sure way to get data back after these firmware errors.

  • @lane: Thanks a lot for this guide! On my Asus Z77 (P8Z77-V), first I had to enable AHCI to enable hotswap, then disable AHCI (=set BIOS to IDE), make sure the SATA connector to the disk was disconnected during boot and connect it during MHDDs SCSI prompt. I could then lock the drive with PWD just as described. My SSD is now back to normal. I hope this helps if anyone else is getting the Failed message during PWD.

  • @mfalkvidd said:

    @lane: Thanks a lot for this guide! On my Asus Z77 (P8Z77-V), first I had to enable AHCI to enable hotswap, then disable AHCI (=set BIOS to IDE), make sure the SATA connector to the disk was disconnected during boot and connect it during MHDDs SCSI prompt. I could then lock the drive with PWD just as described. My SSD is now back to normal. I hope this helps if anyone else is getting the Failed message during PWD.

    Glad that you got your drive back up and running!

  • Hi,

    Sorry to dig up this old post, but I'm just hoping someone can help me with a problem.

    I have a 320 Series SSD from Intel and I had the 8MB bug. I followed the guide posted here but it wouldn't recognize the FASTERASE command and the drive now shows as locked when I boot the PC. I tried the password I had set as per the instructions but to no avail.

    Is their any way I can recover the drive? It shows up in "Computer Management" and it is showing its correct capacity now, but obviously its still locked.

    hoping someone can help me with this one! thanks. :)

  • Geeez!! Bookmarked this like 4 years ago because i got an intel SSD (320 series i believe), and now when it crashed and i was going to look from my external Linux for salvageable data before ordering a new drive I by accident saw the drive was showing 8MB, foggily remembered something, put '8MB' into my bookmark-search, dug this out, and VOILA! Its exactly the same symptom! Only it says BAD_CTX 00000130 (the last figure is 0 not F). Hopefully, I'll get my drive back now, put in yesterdays backup, and that's that :-D:-D:-D Signed up here just to post this and say: THANK YOU THANK YOU THANK YOU SO MUCH!!! If it doesn't work out, I'll get back here and edit, otherwise consider me another late happy Intel SSD Harddrive Resurrector :-D
  • Heureka, it worked. I have the whole 120 Gigabyte showing, I'm confident the rest will go smothely. I did not, however, follow this guide after all but this one:, from an Ubuntu installation on a usb-stick to circumvent the 'drive frozen -> hotplug drive' problem. Worked perfect, at first I still had 8 MB showing, but after a shutdown and reboot into Ubuntu, its back to normal. I'm now recovering from a previous System-Backup and am very happy..

  • hi, i have an intel ssd 330 on my mac and replaced it with a new 850 evo... after removing and exchanging from my mac and putting it to my new acer laptop, before doing so, i plugged my old ssd 330 to my mac via external drive to check the files i left there and boom its gone! :( then after that i researched for bricked and found this article...

    i tried doing the burning of image of ver 4.5 MHDD, but when i do this on my bios on my acer laptop. the ISO file is not working.. its just bypassing the ISO file and go directly to my windows. is there something i could do to make the ISO work? so i can rescue my dead intel 330?

    thanks in advanced! \


  • h!

    i managed to get to the bootable CD. but then its telling me that i dont have enough memory..

    what should i do?

  • Geeez you saved many of us.!!!

  • Is this hard drive guide authentic according to your opinion.

  • Very informative thread.

  • Nice thread on <a href="">cameras</a> and hard drives.