Help figure out my Aero issue, please...

Created by SPACETURTLE on March 15, 2012, 7:14 p.m.
  • Hi!
    I bought a new rig right before Christmas sometime, and when I got a reasonable deal on windows 7 64-bit I went for it. So far I'm very happy with Windows 7 and the Aero "software" (or whatever I should call it) is looking sweet! Anyways, I have noticed when I launch certain games or programs Aero shuts down and changes my desktop theme to windows 7 basic color. And that is all fine cause when I'm in-game it really doesnt matter how my desktop looks. But today when I turned on my computer Aero was already off  and basic color had replaced it as if I had launched a game that usually turns Aero off. An example of a game that usually does this is BC2. Never the less, I found out what caused Aero to turn off. It seems Steam is interfering with Aero the same way BC2 does when I launch it. But what is strange is that I've had Aero and Steam on the computer since I bought it and this has never happened before. So I think its weird Steam suddenly ain't compatible with Aero anymore.
     
    Sooooo, if anyone got any solutions to this issue of mine I would greatly appreciate it if you would share them with me. Thanks in advance!

  • @SPACETURTLE: Can you turn it on again by going in to the Personalize settings?
  • Sounds like Steam is changing your desktop composition settings.  You can check to see if this is the case by right-clicking the Steam shortcut and then clicking on properties.  Under the compatibility tab, make sure that you aren't running the application in compatibility mode, and make sure that the checkbox for  'disable desktop composition' isn't checked. 
  • @SPACETURTLE: you can also restart Aero manually, by running the command prompt as an administrator and typing the following: 
     
    net stop uxsms 
    net start uxsms
  • Alright! Thanks guys. I'm not at home right now, so I'll check it out when I am. I forgot to mention, I cant just turn Aero back on in personalize settings. Changing themes doesnt work either.
  • @Rolento: 
    Dude, awesome! You were totally right! The issue was the Steam property settings. I forgot to uncheck them again after trying to fix a issue I have with BC2 which I ordered of Steam. I tried to make BC2 more DPI compitable by going under the compitable tab in the properties for my BC2 shortcut and messing around with the checkbox's. But since BC2 works through Steam the settings I changed only had an effect on Steam and not the game.
     
    Anyways, Thank you for helping out!

  • Oh, sweet.  Happy to be of service.  I knew there was *some* reason I took that Win7 MCTS exam...  ;)