Cyborg R.A.T. 7 Mouse Issues

Created by Mattalorian on March 15, 2012, 6:21 p.m.
  • @mattalorian: This exact thing happened to me before, but I don't remember how I fixed it.  I think all I had to do was restore the default functions in the driver.  I was using a MS Sidewinder at the time.
  • Seems like it has to be a driver issue. I've had 2 of them as well but never had the issue you described. Also on Windows 7 x64.

  • SO funny. I chased this for months. Try these options (humor me here, don't laugh, just try them):

    1) Turn down your Sub woofer

    2) Turn off all items on your desktop (NOT your PC, Your IRL desktop). No fans, no PC, no printer NOTHING!

    Seems that the RATT 7 Is too sensitive. It's moving because its picking up vibrations from the environment. Don't think so? Turn up your sub woofer all the way, place it on your desk and play a song. See what happens.

    Even my Pro Challenger Tt Keyboard small little fan is enough to make is move.

  • Hello. I am experiencing the same issue; first I thought it might be the OS drivers or some other problem, and I went through lengthy troubleshooting process:
    - reinstalled all the USB drivers on my windows 7 32-bit,
    - reinstalled / un-installed RAT7 drivers,
    - overclocked USB ports to 250, 500 or 1000 Hz,
    - went through full USB troubleshooting and mouse polling analysis
    - double-checked my power supply,
    - re-plugged mouse in every single one of my 6 USB ports at the back of the mobo, also trying number of combinations, port resets, plugging it with ps2 keyboard and nothing else, etc.

    Brian - your advice fails to fix the issue simply cuz there is no such "vibration noise" on my desk, I use headphones most of the time. Mouse is glitchy and stuttering with either vertical or horizontal movement, sometimes both, while I use it and hold it in my hand - all the vibration should be amortized through the wrist (I use claw grip). Also, if mouse is not used for couple of minutes, idling on the desk, it takes couple of moves or circles with it to fully "wake it up". Really annoying. Also, all the time, I have the feeling like it just "drops" some frames, thus my moves on the desktop somehow end up "short" most of the time, if you understand what I am saying. I.E, its really funny when I try to aim at the "close" button on some window, or something. It does not feel precise, because of those "frame drops".
    This morning I brought RAT7 to work and tried it with Ubuntu and WinXP; issue persists, exactly the same as mattalorian described it. I am slowly going nuts, and now I am wondering should I return mouse, shall I get another shitty imprecise mouse, should I try to change it for some other mouse...crap. And I am back to using my old G5 till I figure out what to do with this and how to fix it. Crap crap crap, I spent hundred Euros on a mouse  and got only a problem for my money. If anyone finds a solution, please post here.
  • @apatrid: I'd start looking for a new one, my R.A.T. 5 had the same stutter and wouldn't do diagonals for a while. Then it just stopped working. I've gone through a couple RMA (which itself takes months) with Mad Catz and I can't say I'm pleased with the quality. Now I just need to go back and research mouses.
  • I have the same problem as BrianCub, but the strangest thing is, it happened to me before. I had CM Storm Sentinel Advanced prior to R.A.T. 7 , and it did the same thing. Gradually, it would take about 1 minute, to "wake up". First, it would be unresponsive, but when I click a button, it would restart itself and the OLED would flicker for a while. So naturally, I had it returned under a warranty, and they gave me a new one. Now, it rests peacefully, in my storage area.
    Now, I'm troubled because the RAT is acting almost the exact same way, with addition to it occasionally refuses to go horizontally  or vertically, as described by previous members here.

    The only link I could find between these mice is the Twin-Eye Sensor. They both use them.
    That, and the fact that they both worked over the NOVA MicrOptic Winner II.  Could it be that the pad is causing issues with the sensor?
  • I have been having this issue on and off for a while now and i did every software related trouble shooting process that was availible to me, nothing worked. But then I read @Antares reply:
    The only link I could find between these mice is the Twin-Eye Sensor. They both use them. That, and the fact that they both worked over the NOVA MicrOptic Winner II.  Could it be that the pad is causing issues with the sensor?
    and it motivated to me to look at the sensor. Upon close inspection i noticed that there was a tiny cat hair stuck in the little sensor hole. I then carefully removed it and Voila! it works fine!  
    I suggest you all take a close look at the sensor. Also I'm impressed that a small hair managed to cause all that commotion, sensitive much!
  • I'm using the R.A.T. 7 too, I've had it a month or so and thus far haven't noticed many problems. I do need to make sure I keep my desk mega clean though, cause like someone mentioned above, a little dust or hair or anything can cause problems for the sensor.

  • I have the RAT 7 and mine works great most of the time. I did notice it is a very sensitive mouse and when it comes to dust on my mouse pad it starts to lag when there is to much dust, even dust you can not see. Every month or so I use compressed air to blow the mouse pad and the bottom of the mouse.

    @mattalorian As for the original issue posted I would say make sure you remove all old mouse drivers. Also make sure the mouse is flat to the desk and that you did not over adjust it so it no longer sits flat to the desk (with you hand on and off the mouse)

    Be sure to look at the Cyborg support page as well:

  • Mine has a tendency, like once a day or so, to just suddenly not want to move either in the Y or the X direction. At that point I have to lift it up, smack it down on the desk once, and it's fine again. 
    Also, my thumb wheel doesn't work at all, for some reason :( Anyone else had thumb wheel issues?
  • @cassus said:

    Mine has a tendency, like once a day or so, to just suddenly not want to move either in the Y or the X direction. At that point I have to lift it up, smack it down on the desk once, and it's fine again. Also, my thumb wheel doesn't work at all, for some reason :( Anyone else had thumb wheel issues?

    I get the same issue with it not wanting to move on one of the axis randomly. Have to do the same thing too. lol One bump on the desk and it works again.

    As for the thumb wheel, by default mine didnt work either. I had to go into the profile editor and change it to left arrow and right arrow(or whatever you want) to get it to work like I thought it was going to by default.

  • I had the same issue w/ an expensive, ultra-thick, Steel Series pad (for heavy workflow). I use a piece of printer paper on my physical desktop. No muss, no fuss. No more ghost in my expensive $*$*ing mouse. Come on folks, we spent $90 + on a mouse! What is wrong with us? I even bought the $20 SS pad to boot! Was I drunk? Maybe a little.

  • Hello Guys,

    I never had this kind of error but it's lil bit difficult other mouse I am a Cod4 Player whenever I try it without software or with software in any game zone. it'll stuck for some time and after 15 to 20 sec its work properly. I thought that its wire problem or something else but its not its just USB port Problem always if you plug it in front of your PC it cause of issue and it is must there is no other USB device attached when you are using it thats all...... I love This Mouse toooooo but a problem there is factory problem that most best kinkle screw hole is not on the exact point i really desprate but its okie with me.........

    so guys if i found out the problem then i'll post here

  • @Theory: Hi, My new Rat 7 acted same 3 months after i purchased it. It had all the same problems as you all described: too sensitive or not sensitive when cursor doesn't respond to vertical or horizontal movement. I went through the routines of updating my driver, set it to default, clean my mouse with pressurized air, etc. None worked. Then i saw your posting about the super duper steel mouse pad. I did purchase a new mouse pad when i first bought the Cyborg. The color matched etc.

    I removed the mouse pad. VOILA... it works like a charm. It works best just on normal smooth table top. I tried on a regular mouse pad provided from a video game store. It's not as sensitive (still love it best when it's on a table top) but it works on a regular mouse pad as well. So the problem was that super duper mouse pad. The name of the mouse pad is Rocketfish and neither sides worked. I thought i'd share my experience here ... now, i am falling in love with this mouse again. :)

  • So, I've also got a similar problem with my RAT7 mouse, running it (trying to anyways) on windows8 64bit. my mouse did the standard "I'm going to work for a day or two then start moving around on my own, start clicking things randomly whilst moving upon my own desire." I've had it for a couple months, and about 3 weeks in attempting to use the mouse, all of my USB ports shut off shortly after I plug it in. I checked a few forums, uninstalled and re-installed the driver and software several times. Used a flat surface with and without a mouse pad, book, paper and what not. Yet I'm still running into these problems, not quite sure what to do here... Should I just go buy a different mouse from another manufacturing company or...?

  • @5ilent5tatik I haven't heard of the same thing happening, but that sounds more like a hardware issue if it's clicking things of its own volition and causing the USB controller trouble.

    Mostly I'm commenting to address the drifting issue; I've had this mouse for nearly a year, using it successfully with Arch Linux 64-bit after disabling the pesky mode button which creates problems on Linux. The drifting issue arises for me every month or so, but so far it's been completely solved by giving my Steel Series mousepad a good shake or vacuuming off. The other comments about its oversensitivity to dust are definitely accurate.

  • make sure your mouse pad/surface is one solid colour.

    my razer mamba had these problems and i narrowed it down to my multicolored mouse-pad causing problems when it moved over the different coloured areas.

  • Never had mine click on its own, it just loses an axis or wanders (usually high and right). Nothing mentioned here works aside from - hilariously - lifting it up off the desk and smacking it solidly down again. My other solution is to unplug it, and plug it back in (also tried different ports, some USB 2 and some USB 3, but it's the same on all of them). Safer for the mouse I'm sure, but it takes more time that I don't really want to waste in the middle of a game, and if it breaks... well, I'll get one that doesn't do this, so no huge loss.

    Another thing I've noticed is that the problem often seems to occur when something particularly intense is happening in a game. Not always, but pretty close to it, and always with some type of full-screen program running. The times I've had this happen just browsing sites or on the desktop? Not even one. It's not the kind of thing you don't notice outside of a game, either: moving the cursor up and down or left and right tends to be handy for regular PC use.

    However, the mouse also seems quite dirt sensitive, but its behaviour with a bit of dust or a cat hair in it tends to be more erratic, like I'd expect with any other mouse I use. Now I keep a small maglite on the desk to check for super-fine fibres (could be hair, or from clothing, etc.) as often the ones that trouble it are not visible under the ceiling light alone. They're that fine. That black plastic ring around the sensor seems almost to snag such things and ensure that they get in the way. I'm often tempted to see if I can remove it, but that's probably a bad idea.

  • I have had a similar issue with my RAT5. The cursor will shoot up to the top of the screen or for some reason it seems like the DPI gets auto set to a super slow setting were I need to really force it to come back down. Usually shutting it off and back on will fix it (I have the wireless model)

    A little off topic here but is there another program to use for setting the mouse shortcuts and behaviors? The RAT software seems clunky to me and a little confusing. For instance, I can't get the horizontal scroll wheel to ever work....

  • uninstall HID compliant mouse driver, in device manager located in Mice and other pointing devices, The only Driver should be Mad Catz own so if you have any other uninstall them too. Then Start/control panel/mouse/pointer options, Un-check enhanced pointer precision, Click apply Have Fun

    Win 7 64 same issue never thought to look in device manager for mouse drivers i was looking in programs and install.

  • When I was using the RAT 7 and this kind of thing happened, I'd just hit the sensor with a blast of compressed air. Worked fine.

  • I have had the exact same problem with my RAT7 and I have currently switched to Razor's gaming mouse that looks and feels very similar to it (although i forgot the name of it at the moment) I thought the RAT7 what built great at first but then after having the razor I am just blown away. Now Both the mouse and keyboard I use are both Razors!

  • This is a bit of a lengthy story, so be warned. I adopted my brothers rat 7, one he got before Mad Katz took it over, that he had abandoned for the same behavior you guys are describing. He bought a new G5 and explained that it was a great mouse, when it was working, but he got tired of trying to troubleshoot and fix it and I believe he tried pretty much everything suggested here. So I asked if I could have it, knock yourself out he said,so now I have it. Tried it with no drivers, seemed to work ok with what drivers came with windows. So I looked up and found the latest/greatest drivers from (I found out) Mad Katz. Installed the drivers and began going thru the software and hardware setups to get it the way I wanted it. I play Unreal Tournament online so this mouse seemed like it would be ideal. Setup the mouse in windows device driver, did a complete software setup thru the rat drivers and set up all available settings in the game. All this took about 5 or 6 days of trial/error in which time I didn't experience a single issue of any kind and finally got it right where I wanted and liked it. In windows I was impressed with how smooth it ran and took and instant like to it. In game, it was remarkable. Fast, accurate, reponsive. Multiple times any mouse I've ever used. Last night it started. Middle of the game it started lagging and went downhill fast. Just getting out of the game was painful. Pulled it apart, checked all connections, cleaned the sensor lens with alcohol and blew it dry a can of of air, checked thru the driver setup and restarted system. After restart, the issue was still there and had gotten worse, to the point that the cursor/mouse was unusable. Plugged in old G5 after a hard reboot and tore apart mouse again. At this point I started looking at the connections from the usb cable to the usb board in the mouse itself. Unplugged the cord from the board and attempted to clean the pins and the plug (as best I could considering their size) as thoroughly as I could. Visually both looked ok. Reassembled and swapped mice and rechecked os and mouse settings. Operation seemed to be completely normal with no discernible problems. So I restarted the game, rechecked game settings and began online play. I seemed to be just as perfect as it was when I first started and ran flawlessly for about one to one and a half hours but the issue raised it's head again, basically the same way as before. I kept working with it for about 2 more hours or so but found that each time I would open it up and play with the cable and connection, normal operation would return for short periods of time. At this point, I'm beginning to believe that the fault is in the usb connection in the mouse itself. Whether it's the wiring connections in the plug itself or in the socket, possibly the solder connections on the either, I'm not really sure but I'm going to try replacing the cable from the rat with the one from the G5. My brother has suggested that some people have had some success by resoldering the pin joints on the back of the sensor on the board in the mouse as well, but the cable swap seems easier so I'm going to try that first. I wouldn't be going thru all this if didn't think it was worth it should any of this work. I REALLY liked this mouse while using it. Any other hints/tips/tricks/suggestions would be welcome. Wish me luck.
  • I had a RAT 7 twice and twice it went crazy after a while. I use a mac so this might be different, but after some time of use the cursor started getting jumpy and laggy. Using the activity monitor I noticed the driver gobbling up huge amounts of memory. After an hour of use the driver took up over 2 gb of memory. About 4 gb after 2 hours.

    Eventually I switched to Razor.

  • Ok. I managed to carefully, completely tear down the Rat 7 and remove the cord. It plugs in to a female socket under the right mouse button and is snaked in tight on the left side of the micro switch under the left mouse button and under a daughter board (also on the left side of the mouse wheel) wired to the thumb wheel rotation sensor and two micro switches for the button behind the main mouse scroll wheel. There was a small ribbon cable that I didn't disconnect for fear of damaging it or being unable to get it reconnected so I had to be extremely careful not to twist it or crease/tear it during the process but managed to do it without too much trouble. There is also a 4 or 6 pin socket on the bottom of the daughter board that I had to be careful of when remounting it, but again, was not too much trouble, I just took my time. After getting the cord disconnected and removed, I tore down the G5 I planned on scavenging the cord from. Although the cords initially looked the same or similiar, the plug on the G5's cord was just slightly ( talking less than .5 mm's) larger than the Rat's. So, reassembled the G5 and set aside. Took the Rat's cord, straightened out the kinks from the original installed routing and thoroughly cleaned the plug and the board's socket as well as possible using elec. contact cleaner and carefully reassembled the Rat making sure the cord routing wasn't bent and twisted the same way as before. Before I started this, I had downloaded and installed the latest/greatest drivers and software from Mad Catz so I plugged the Rat in and restarted my system. I honestly expected it to completely die on restart but, believe it or not, it worked perfectly. I did this right after I posted my original message. I've got all the settings in win 7, Unreal and in the Rat's software set pretty much where I want and have been using it daily, since, with out any problems whatsoever. Nary a hiccup. Again, too be honest, I don't have the greatest confidence that whatever the problem might have been is truly solved and I'm left, basically waiting for it to take a crap at any moment but until then, I'll enjoy using it. I did hear back from Mad Catz a couple days ago and their suggestion was to uninstall/reinstall the latest drivers and software and try it again. However, I think the problem is hardware related so I'll wait until it acts up again before I do that since it's working fine for now. I found out when initially filling out the service ticket that it was originally purchased in Feb. of 2014, so the warranty is almost up. I didn't tell them I tore it apart, didn't think it would be prudent at this juncture.

    At any rate, I'm not suggesting this is in any way a fix of any kind since I came away with absolutely no clear answer that would suggest a specific problem although I'm still convinced it's internally hardware related since the nature of the symptoms seem to suggest it. I emailed Mad Catz again and basically told them it's working and I'll let them know when it acts up. I'll remember to post here again, if/when it decides to head south once more.

  • For whatever weird reason, unplugging my RAT 7 mouse from the computer always made it work again. I've done this about 15 times, worked 100% of the time. I'm unsure of the significance of unplugging the mouse but... I can't argue with the results. I have just started unplugging it during sleeping hours and never have a problem. If I forget to unplug it for a while I get the stuttering cursor until it just stops completely and I just unplug for a while and it's working fine again.

  • @Mattalorian: OK, I'm not sure how much people still need this information. I'm still using RAT7 and I think I found a fix for this problem. Uninstall official mad Catz drivers. Even thou, you won't be able to program the buttons, unless the game itself lets you like CS:GO, but at least you will be able to use it