Transcoder Feedback

Created by will on Feb. 20, 2015, 7:48 p.m.
  • Sticky
  • I can import the vm into my hypervisor, is there a way to log into the black box ?

  • @Bedon292 I got your docker version of the transcoder to install it creates the files input work etc the only problem i've found is permissions, if i try and write an mkv to the input folder i get a permission denied error ?

  • @Bedon292 if i specify /media/transcoder as the container volume then map a host path to my share the folders are created but i don't have permission to write to the input file, thought a screenshot may help

  • @Valherun: I briefly mentioned it in an earlier post, but what I did was use the phpVirtualBox template which is already configured to work. Unfortunately vagrant does not work with it, so I had to set up the scripts manually. Though I will make a shell script for it to simplify the process.

    Under the Jails tab at the top there is a tab for Templates, and if it does not already exist, you can add Then when you add a jail hit advanced and choose that template. As soon as it boots phpVirtualBox is working, and you can go from there.

    Some day I am going to get it right, but I have fought with it for two weekends so, its an eventually thing. I have it transcoding right now, just not as nice a setup.

  • @MrCoe1989: Thats interesting, did not expect a permission issue there. Can probably modify the script to set the permissions to totally open on the directories for further use. For now though, you could probably try to get rid of those folders, and create them yourself with open permissions.

    What GUI is that by the way? I do all my docker stuff from the CLI and do not recognize it.

  • The Gui is for an unraid server, docker is part of it :-)

  • If you could set it to totally open id be happy to test it for you, in the screenshot ive posted above i've specified the container volume as /media/transcoder and then mapped it to my host drive, i got around the permissions error by specifying the container volume as something different "/media" for example. it created the input out files etc but it didn't start converting so i assumed the path needed to be /media/transcoder

  • @Bedon292 You're a legend mate, once i deleted then replaced the folders the permissions error went away and the dock app works beautifully, encoding speed is like lightning and the quality is great :-)

  • @MrCoe1989: Awesome, yeah I will mod the script to set folder permissions so further builds with not have that issue. Need to work on further integration with the vagrant version, because the script has a few modifications. But once that works I can make a shell script to do a local install as well. Hopefully all from the same git, and have 3 ways for it to run as a black box.

  • @Valherun: I have been contemplating the idea of digging up an older version of the vagrant package which does not need to upgrade the other packages. Not sure the feasibility of it, but it could be a solution as well. Great job figuring out how to get it up and running either way. Its a real pain.

    I wouldn't be too worried about running it as root in VB in the jail, its still two levels of protection from the real OS. First whatever would have to escape VB, and then it would have to escape the jail as well. It I were running it directly in VB on an Ubuntu box or something I would be much more concerned. Also, now that the script is running you can remove the network connectivity to the jail as well since it is no longer needed just for that little bit more of safety.

  • So having an oddity/problem -

    Even after adding the shared folder and clicking "make permanent", if I stop/restart the vagrant box, I have to re-add the folder into virtual box. Is there something else that I need to adjust?

    Originally ran this on OS X Yosemite, but the issue still happens in OS X El Capitan.

  • @saintnicster: I never ran into the problem on Windows at least. May be a Mac thing? Although I did end up making a modified version that has settings in Vagrant for it all, which should solve that.

    @Valherun Yeah the web UI definitely sucks, but never have to actually see it once its up and running either.

  • @Valherun: So it's only just now hitting me, but since the scripts really don't seem to update that often, is there much of a benefit to using Vagrant to boot it every time? Or would I be fine with just directly booting the Virtual Box?

    @Bedon292 - Yeah, was thinking that maybe it was some weird permissions thing, but no clue otherwise.

  • That's cool, I actually thought vagrant was needed every time due to user / start issues. The scripts basically never change though, so there is no real need to update them

    In fact I would actually intentionally avoid updating them once they are working the way you want. While an update should not break anything previous, there is always the possibility and no reason to change if its already working.

  • @nhall: Multiple install guides and some more tweaks are definitely something I want to get to, just have not had time. Valehrun does have a guide he made further up the page though.

    Not sure about 720p bit, the purpose of this was highest quality possible so I never looked. Is that what it says to do on Don Melton's page?

  • I just paid for it. As soon as I started using it I knew it was something I wanted to keep around. It is a reasonable price, and I wanted to support him to make sure he keeps it up to date. Over a library of movies, the price is barely noticeable for something so useful.

  • In fact, I realized that this is something a little strange audio. "In fact, adding more track that was not there before.

  • @bdrob16: I can't answer anything about the MP4 side of things, but if you rip the stereo audio in MakeMK along with the 5.1 you will have both audio tracks available. You might be able to tweak the script into going straight to m4v, but I have not tried that yet. I need to re-rip a few movies that I pulled the wrong video from, so I will play with it when I do that.

    Another option would be just keeping them all as mkv in plex, and having plex do the transcoding on the fly to apple devices. I don't have any, but I do transcode on the fly to mobile devices at least and it works well.

  • @bdrob16: It has been a while since I used the original version, I have my own fork I use. I believe the original version which is linked to here, burns in forced subtitles, and gets rid of the rest. My fork passes through all audio and subtitles. If you have interest in that you might want to check it out.

  • Bedon292 When you say your fork do you mean your docker container ?

  • I'm looking into making my own docker fork of it, im new to bash scripting and programming in general

  • @MrCoe1989: I mean my fork of the code on github. Runs the same way as the original, just treats the subs differently. That fork is what I installed in the docker container though. Depending on which way you want to use it which one you want to use.

  • Is there anyway to alter the code ? or any instructions as to how i can build my own fork ?

  • I've finally started the process of ripping and encoding my Blurays, and using the Tested Transcoder VM to do the encoding. After struggling to get the VM working (for some reason, it always prompted me for a password -- some digging found that Vagrant-created VMs use username/password vagrant/vagrant and that worked and got it running, FYI), I've now processed a few movies through it.

    So far it works really well, but there's something really, really weird with the output, which is the variance in file size. Some movies (Mad Max Fury Road, John Wick, Event Horizon, Mission Impossible Rogue Nation) come in at between 3.5-5GBs or so. But others (Fast & Furious 6 and 7, Kingsman) come in at 9.8-11GBs. That's a huge variance in file size, and I can't figure out what the hell the difference is that would cause those encodes to be so large.

    Any ideas?

  • I am trying to get this to work on Windows server 2012 R2 and I am a complete noob. I get the machine in load and run but it won't create the media folders. Any help would be great!
  • Hi, Transcoder doesn't seem to recognise the Blu-ray ISO but does recognise a DVD iso? Also if I rip a Blu-ray to MKV Transcoder doesnt recognise the 7.1 DTS audio track, it skips it completely. It does however recognise the 5.1 track without issue? Is there anyway i can change the configuration of Transcoder to recognise the Iso file and identify the 7.1 audio track?

  • @ArmaExSanctus: Been a while since I checked on this thread, but that is normal. Different movies compress differently. Unlike some methods of compression that aim to make everything the same side, this aims to make everything the same (highest possible) quality. Which will depend on a huge number of factors. The big one is actually sound. If you have a bunch of different sound tracks going through it will be bigger. For example, if there is a commentary track, or in the case of Anime, English and Japanese audio. It all adds up. Or higher quality surround like DTS or whatever.

  • I didn't actually rip my movies with 7.1 even though I should have to future proof them. I believe that is a problem with handbrake not supporting TrueHD but I think it should support DTS-MA 7.1 you will probably need to look into handbrake for the issue though. The scripts can only do what handbreak allows. Now if hanbrake does allow it (you can install it manually and check) then I can look into the script and see what is up.

  • I've noticed that the original scripts have become depreciated is there a way to update those scripts ?

  • @MrCoe1989 said:

    I've noticed that the original scripts have become depreciated is there a way to update those scripts ?

    Which scripts are you referring too? I am actually working on ripping a bunch of DVDs now, so I wouldn't mind looking at them. But mine is chugging along fine.