@Will - Aeropress with Zojirushi mug

Created by Leekspin on March 15, 2012, 7:20 p.m.
  • I got the Zojirushi mug from your review and have a problem with the Aeropress. Before I would just put the aeropress on top of my travel tumbler and press into it but now with the Zojirushi the opening is way too small for that. How do you use the aeropress with the zojirushi mug?

  • @Leekspin: Your aeropress should have come with a funnel for smaller cups. It's a pretty big plastic piece and the aeropress just sets down in it. I've aeropressed into my Nissan thermos before (it's basically the same as the Zojirushi), just made the coffee stronger and added a little more water afterward.

  • @will: You know, the idea of using it as a funnel for coffee grounds had never crossed my mind....

  • I tried using the funnel but it was just a bit too big and wouldn't fit in the zojirushi hole. I've just been making my coffee in the chemex which is fine it just takes a bit longer in the morning instead of the aeropress

  • Pardon me while I zombify this thread... in case anyone else googles upon it as I did, I've found this vacuum insulated travel cup to be pretty awesome. I've bought two.

    "Thermos Stainless King 16-Ounce Travel Tumbler"

    http://amzn.com/B002PY7AYS

  • I'd highly recommend any of the contigo mugs (e.g. http://www.gocontigo.com/16-oz-autoseal-west-loop-stainless-travel-mug.html). They are amazingly good at retaining heat for several hours and don't spoil the flavour at all.


  • For @Leekspin or anyone else looking for a funnel to go between an Aeropress and a Zojirushi mug, this is the only funnel i've found online with the proper diameters. It comes in a 3-pack, with 2 other funnels that seem too small to be useful for anything else. However, it fits pretty well:

    It gets a bit top-heavy with liquid in the press of course, and I would have preferred a similarly sized canning funnel to make things a bit more stable, but this still worked well and didn't fall over when I pressed the coffee out. Might want to hold on with both hands though.