Iphone: need to turn off email alert

Created by doe3879 on Oct. 31, 2012, midnight
  • I'm sorry to be asking this dumb ass question and I feel like an idiot for asking myself. I don't know what I sign up for recently and been getting email spam all day and the alert is driving me mad.

    I've tried turning all mail related notification off. Set all the Mail related setting to "none" in Sound settings. Didn't solve it.

    Please help, I have whatever the newest iso version is.

  • Have you gone into the Mail settings in "Settings" and turned off push notifications? That should stop you getting alerts.

  • @HKZ: I do not see push notifications settings within "Setting > Mail, contact, calenders" but I have turn off Mail within the "Notifications" setting

  • It should be in "Settings>Mail, contact, calenders" directly underneath your email accounts like this:

    http://goo.gl/7hqRL

  • @HKZ: resolved it after half an hour of google.

    Apparently I have to leave the Mail notification "On" while having the Sound set to "none"

  • Oh okay, cool!


  • Alternatively, have set the phone to check for mail 'manually'. If you don't want notifications at all, might as well save yourself a bit of battery.