Strange, annoying problem using 40" TV as PC monitor for videos, games etc. Blurry text, terrible frame rate. Please help!

Created by TooWalrus on May 5, 2015, 5:46 p.m.
  • I've been using a Dynex television as a PC monitor for a few years now. It used to work flawlessly. I moved last year and I'm not sure what changed, but now it's giving me nothing but trouble. I've tried using multiple HDMI cables, so that doesn't seem to be the issue. Here's the problem. The resolution just doesn't look right. Both the PC and TV are set to 1080p, but text never looks right. It's not an overscan issue either, I've tried every solution I can find by simple googling. I've done my fair share of messing with settings. I'm using two monitors, everything looks perfect on my ASUS monitor, but not on the TV. There are actually two major problems. The second is the frame rate. I guess I don't know exactly how to define the problem, maybe it's a bitrate thing? The best way I can explain it is that video just looks laggy, like it's not smooth, it's missing frames or something. I've never had a problem playing 1080p video (and it seems to happen with 720p video and even DVD rips). Watching Netflix on my PS4 is silky smooth, but from my PC it looks like garbage. Same goes for local files. Any video is pretty much unwatchable on this TV and it's driving me crazy.I don't THINK it's some kind of issue with my PC being outdated, I'm using an i7 2600k and GeForce 680, and video runs silky smooth on my monitor, even full 1080p video. Here are a few pictures, but it's hard to photograph the exact problem.The first is of my monitor, the second is of my TV. Maybe someone else has had this issue before and knows what I'm talking about. I've always gotten great help from Tested in the past, hopefully this time is no different! Thanks!

    Silky Smooth Text
    Choppy awful text

  • That's a display problem, not a computer problem. What is your screen refresh rate set to? Right Click Desktop > Screen Resolution > Select display > Advanced Settings > Monitor Tab > Refresh Rate.